Utiliser Eclipse

De Analyse Développement Hacking
Sauter à la navigation Sauter à la recherche
Naviguer dans ce wiki : Accueil du wiki - Objectifs - Administrateur - Bureautique - Développeur - Intégrateur - Marketing - Multimédia - Objets numériques - Jeux - We make Hack
Consulter le site : Accueil du site - Annuaire - Blog - Forum - Outils - Utilisateur     Consulter le Redmine : Accueil du Redmine

Utiliser Eclipse

Développé originellement par IBM à partir de Visual Age, Eclipse est un EDI, Environnement de Développement Intégré.
Le logiciel a été rendu open-source et est maintenant maintenu par la fondation Eclipse Foundation Software.
Cette fondation est composée d'un grand nombre de membres et est dirigée par un conseil d'administration.
La conception de Eclipse est complètement modulaire ce qui fait d'Eclipse une boite à outils facilement modifiable et extensible.
La license de Eclipse permet de fournir des plug-ins open sources comme des plug-ins closed-source.
Eclipse gère un grand nombre de langages de programmation. (PHP, C, C++ ...)
Eclipse RCP (Rich Client Platform) sert de socle à 29,672,070 applications.
Consulter la page Eclipse Marketplace : http://marketplace.eclipse.org
Eclipse.png

Installation

Installer JAVA

Eclipse a besoin de JAVA pour fonctionner.
Le dossier JRE de JAVA peut être placé dans le dossier de Eclipse pour ne pas avoir à installer JAVA.
Installer OpenJDK 8 pour permettre à Eclipse et à d'autres programmes de fonctionner sans avoir à placer le dossier JRE dans le dossier de Eclipse.

Installer Eclipse

Le site officiel de Eclipse : https://www.eclipse.org
La version de Eclipse lors de la rédaction de cette page est Eclipse Photon.
Télécharger et installer Eclipse depuis la page de chargement officielle de Eclipse : https://www.eclipse.org/downloads/
La version de Eclipse pour développer avec PHP est Eclipse PHP Development Tools (PDT).
Télécharger et installer Eclipse PDT depuis la page de chargement officielle des paquets Eclipse : https://www.eclipse.org/downloads/eclipse-packages/
Distribution PDT : Les outils essentiels pour tout développeur PHP, y compris le support du langage PHP, le client Git, Mylyn et les éditeurs pour JavaScript, HTML, CSS et XML.
La version de Eclipse pour développer pour le web est Eclipse IDE for JavaScript and Web Developers.
Télécharger et installer Eclipse pour le Web depuis la page de chargement officielle des paquets Eclipse : http://www.eclipse.org/downloads/packages/eclipse-ide-javascript-and-web-developers/photonr
Les outils essentiels pour tout développeur JavaScript, y compris JavaScript, HTML, CSS, support des langages XML, client Git et Mylyn.
Eclipse peut également être directement installé depuis les dépôts GNU/Linux.
sudo apt-get install eclipse
Capture d'écran de Eclipse Mars.

Ajouter Eclipse au menu Cairo-Dock

Ajouter un raccourci personnalisé pour Cairo-Dock sous GNU/Linux permettant de lancer Eclipse.
Utiliser la commande suivante :
Exec=/bin/bash /home/USERNAME/Eclipse/eclipse
Sinon, rendre /home/USERNAME/Eclipse/eclipse exécutable :
sudo chmod u+x /home/USERNAME/Eclipse/eclipse
Puis, utiliser :
Exec=/home/USERNAME/Eclipse/eclipse

Ajouter une entrée dans le menu XFCE

Ajouter une entrée dans le menu XFCE de Debian 8.7 Jessie :
Ajouter une entrée dans le dossier /usr/share/applications/ qui s’appellera Eclipse.desktop pour voir le raccourci ajouté au menu XFCE.
Il est plus propre d'utiliser le dossier de l'utilisateur : /home/USER/.local/share/applications/
[Desktop Entry]
Version=1.0
Type=Application
Encoding=UTF-8
Name=Eclipse
GenericName=Eclipse
Comment=Eclipse PDT : PHP.
Icon=/home/USER/PATH/Eclipse/php.png
Exec=/home/USER/PATH/Eclipse/eclipse
Terminal=false
StartupNotify=false
# OnlyShowIn=XFCE
Categories=Development;

Configurer Eclipse

Ajouter le dossier de travail Workspace

A l'ouverture Eclipse demande un emplacement pour son dossier Workspace.
Le choix de l'emplacement du dossier Workspace n'est pas important pour un usage minimaliste.
Le choix de l'emplacement du dossier Workspace est important dans le cas d'un serveur Web local devant utiliser les ressources présentes dans le Workspace.
Placer le dossier Workspace dans votre dossier interprété par le serveur Web, souvent, le dossier www, ou, le dossier htdocs, ou encore, le dossier html.
Par exemple pour Xampp sous GNU/Linux : /opt/lampp/htdocs/Workspace

Auto complétion

Pour configurer l'auto complétion de Java, aller dans Fenêtre/Préférences/java/editor/contentAssist/
Pour configurer l'auto complétion de PHP, aller dans Fenêtre/Préférences/php/editor/contentAssist/

Mettre à jour

Help > Check for Updates.

Changer le thème graphique

Fenêtre > Préférence > Généralités > Apparence > Thème.
Choisir le thème sombre.
Redémarrer Eclipse.

Installer un nouveau thème

Installer le plugin Eclipsecolorthemes : http://eclipse-color-theme.github.com/update
Télécharger d'autres thèmes depuis Eclipsecolorthemes : http://www.eclipsecolorthemes.org
Source : https://www.mkyong.com/eclipse/how-to-change-eclipse-theme/

Changer l'encodage

Pour travailler sur un environnement hétérogène (Mac, Windows, Linux), UTF-8 est définit comme la valeur par défaut.

Changer l'encodage général au niveau d'Eclipse

Window > Préférences > Généralités > Types de contenu, cliquer sur Texte, ajouter la valeur UTF-8 pour l'encodage.
Window > Préférences > Généralités > Workspace, cliquer sur "Codage du fichier texte" et choisir la valeur UTF-8.
Passer le Default (Cp1252) en Other UTF-8

Changer l'encodage d'un projet, en cliquant droit sur le projet

Sélectionner "Properties" dans le menu contextuel
Dans la partie "Info", plus précisément "Text file encoding", sélectionner UTF-8

Changer l'encodage d'un fichier, en cliquant droit sur le fichier

Sélectionner "Properties" dans le menu contextuel
Dans la partie "Info", plus précisément "Text file encoding", sélectionner UTF-8

Paramétrer le navigateur par défaut

Utiliser Firefox Developer par défaut. Fenêtre > Préférences  > Généralités > Choisir ou ajouter un navigateur web.
Ouvrir un fichier en cliquant droit, ouvrir avec, Autres, Navigateur web ou Navigateur Web interne.

Rafraîchir les fichiers

Paramètres de rafraîchissement des fichiers et sauvegarde.
- Générer automatiquement : Est coché par défaut avec Eclipse Luna.
- Sauvegarde automatique du code source avant génération : Cocher dans Préférences > General > Workspace > Save automatically before build
- Recharger automatiquement un fichier qui a été modifié sans passer par Eclipse : Cocher dans Préférences > General > Workspace > Refresh On Access
- F5 permet également de rafraîchir un fichier Eclipse.

Installer de nouveaux logiciels/composants

Ouvrir l'installeur depuis 'Help' > 'Install New Software...'

Changer la langue

Eclipse en français avec le pack de langues du projet Babel.
Sauvegarder le dossier Eclipse et le dossier de travail avant de tester Babel.
Penser que Eclipse plante très souvent avec Babel installé. Rester en version anglaise de préférence.
Installer le pack de langue, d'après le site officiel :
Trouver le lien à utiliser pour le pack de langue de la version courante : http://www.eclipse.org/babel/downloads.php
Ouvrir l'installeur depuis 'Help' > 'Install new software...'
Ajouter le lien vers le répertoire de Babel : https://download.eclipse.org/technology/babel/update-site/R0.17.0/2019-06/
Select/install your language pack of choice
Choisir Babel Language Packs for Eclipse in French pour mettre en français le socle de Eclipse (88% traduit.)
Choisir les autres paquets de langue en français pour traduire les modules complémentaires.
Préférer les paquets avec un pourcentage élevé pour le taux de traduction existant.
Inutile de risquer des conflits pour une traduction effectuée à 5%.
Exemple : des fenêtres de perspectives qui ne s'ouvriraient plus.
Suivant. Valider la licence. Fini.
Patienter durant le chargement.
Redémarrer Eclipse.

Outils à utiliser

Liste des tâches

La liste des tâches (Task List) permet de créer une liste de tâches à faire.
Fenêtre > Afficher la vue > Tâches

Historique de versions de fichiers

Depuis Eclipse Ganymede, la gestion des versions de fichiers est prise en charge avec le Local History.
Consulter la liste des révisions dans l'écran du bas, dans l'onglet Commun.

Indenter le code en PSR / PSR-2

Les lignes NE DEVRAIENT PAS être plus de 80 caractères. Les lignes plus longues que cela DEVRAIENT être divisées en plusieurs lignes ultérieures de 80 caractères maximum chacune.
Je ne sais pas si cette norme s'applique au code PHP, si je tente de l'appliquer, les lignes débordent de la marge de 80 caractères.
Fenêtre / Préférences / Généralités / Éditeurs de texte / Afficher la marge d'impression de 80 caractères.
Eclipse intègre PhPCodeSniffer :
Formater le code PHP directement avec Eclipse ne devrait pas modifier le dernier caractère de fin de ligne Windows ou Unix.
Il suffit de cliquer droit sur le Code source / Source / Format.
Si nécessaire, nettoyer le code permet de modifier le dernier caractère de fin de ligne, depuis un fichier / clic droit / Code source / Nettoyer.
Source : Prepare eclipse for PHP (PSR standard) : https://ratanparai.wordpress.com/2014/10/16/prepare-eclipse-for-php-psr-standard/

Utiliser Git avec Eclipse

Utiliser Git avec Eclipse.

Interpréteur PHP

Configurer PHP pour exécuter du code localement

Configuration minimaliste

Dans mon cas, un serveur Xampp est installé sur GNU/Linux Debian Jessie.
Depuis un script PHP "Bonjour le monde" cliquer sur la petite flèche noire à droite de l'icone vert play, qui permet de lancer l'interprétation du code PHP.
Créer le dossier de travail de Eclipse dans le dossier du site utilisé par défaut par le serveur web.
Indiquer le chemin vers le fichier à exécuter vers le dossier de travail.
/Eclipse-Workspace/Hello-World/helloworld.php
Le rendu dans le navigateur sera : http://localhost/Eclipse-Workspace/Hello-World/helloworld.php
Le rendu sera : Hello World

Configuration standard

Configurer PHP depuis Fenêtre > Préférences > PHP > Servers
Ajouter un environnement PHP exécutable en cliquant sur le bouton Add.
Sous onglet Server
Donner un nom à cette configuration, typiquement la version de PHP utilisée. Par défaut : Default PHP Web Server.
Base URL : http://localhost
Document Root : /opt/lampp/htdocs/Eclipse-Workspace/

Installer xdebug

Installer xdebug sur un serveur local Xampp

Installer xdebug sur Xampp.

Configurer Eclipse avec XDebug

Configurer un navigateur par défaut dans Windows/Préférences General/Web Browser. 
Depuis Fenêtre > Préférences > PHP > Debug > Debuggers
XDebug doit être sélectionné comme débogueur PHP.
Configurer Xdebug avec localhost dans la liste de choix Accept remote session (JIT)
Depuis Fenêtre > Préférences > PHP > Servers
Sous onglet Debugger : Choisir xdebug une fois xdebug installé.

Utiliser xdebug

Ouvrir un fichier php.
Aller dans le menu Exécuter et sélectionner Déboguer.
La touche F11 permet d'interpréter la page sur le navigateur intégré à Eclipse.
Si la page PHP n'affiche pas de contenu, vérifier que le lien appelé correspond bien à l'emplacement du fichier.
Sinon, aller dans Exécuter > Exécuter les configurations.
Si la fenêtre de debogue a été fermée, et, refuse de s'ouvrir à nouveau, vérifier que le carré rouge ait bien été cliqué pour arrêter le mode debogue.
La fenêtre du bas, Problèmes, affichera par exemple les variables qui ne sont pas utilisées dans le script.
La fenêtre de droite, Struct, affichera par exemple les variables présentes dans le script.
Des modèles de debogue peuvent être créés à l'aide de points d'arrêts.
Ok.png Configurer XDebug sous Linux pour Eclipse IDE : http://docs.joomla.org/Configuring_Xdebug_for_PHP_development/Linux
Ok.png Apache Xampp : http://unitstep.net/blog/2009/01/26/getting-xdebug-to-work-with-apachexampp-to-debug-php/
Ok-ko.png Debugging using XDebug : https://wiki.eclipse.org/Debugging_using_XDebug

Sauvegarder Eclipse

Avant chaque installation de nouveaux composants sur Eclipse, faire une copie du répertoire qui contient le programme Eclipse ainsi que du dossier de travail qui contient votre projet.

Les raccourcis de Eclipse

Introduction aux raccourcis

Afficher la liste de tous les raccourcis clavier
Ctrl+Shift+L
Gestion des imports
Le raccourci Ctrl+Shift+O (aussi accessible par le menu contextuel 'Source->Organiser les importations') gère la liste des imports :
Les imports manquants sont ajoutés, les inutiles supprimés et la liste est  classée.
Ces actions se font conformément aux paramètres définis dans Préférences->Java->Style de code->Organiser les importations.
Formatage
Le raccourci Ctrl+Shift+F déclenche le formatage soit de tout le fichier soit des lignes sélectionnées. Les options de formatage sont configurables dans Préférences->Java->Style de Code->Formater.
Autocomplétion du code lors du développement avec Eclipse Ganymède : Ctrl Espace
En cas de difficulté : Préférence / java / editor / Content Assist / Advanced et vérifier si tout est coché. 

Édition

Raccourcis Action
Ctrl+Espace Assister au contenu (dont autocomplétion)
Alt+/ Complétion du mot
Ctrl+Maj+Espace Informations de contexte
Ctrl+Maj+Y Mettre en minuscules
Ctrl+Maj+X Mettre en majuscules
Alt+Maj+O Marquer/démarquer les occurrences
Ctrl+C / Ctrl+Insert Copier
Ctrl+X / Maj+Suppr Couper
Ctrl+V / Maj+Insert Coller
Ctrl+Alt+Haut / Ctrl+Alt+Bas Dupliquer la ligne en cours ou des lignes sélectionnées (en haut ou en bas)
Ctrl+D Effacer la ligne
Ctrl+Suppr Effacer le mot suivant
Ctrl+Arrière Effacer le mot précédent
Ctrl+Maj+Suppr Effacer jusqu'à la fin de la ligne
Ctrl+Maj+Entrée Insérer une ligne au-dessus
Maj+Entrée Insérer une ligne en dessous
Home Aller en début de ligne
Fin Aller en fin de ligne
Alt+Bas Descendre de N lignes
Alt+Haut Monter de N lignes
Ctrl+Droite Aller au mot suivant
Ctrl+Gauche Aller au mot précédent
Ctrl+Bas Scroller vers le bas
Ctrl+Bas Scroller vers le haut
Ctrl+Home Aller en haut du fichier
Ctrl+Fin Aller en bas du fichier
Ctrl+Maj+Q Basculer en diff rapide
Ctrl+1 Proposer une solution rapide
Ctrl+Z Défaire
Ctrl+Y Refaire
F2 Afficher la description
Ctrl+Maj+Insert Basculer en mode insertion
Alt+Maj+A Active/désactive le mode colonne
Ctrl+Maj+L Afficher tous les raccourcis

Sélection

Raccourcis Action
Alt+Maj+Bas Restaurer la dernière sélection
Ctrl+A Sélectionner tout
Alt+Maj+Haut Sélectionner élément englobant
Alt+Maj+Droite Sélectionner l'élément suivant
Alt+Maj+Gauche Sélectionner l'élément précédent
Ctrl+Maj+Droite Sélectionner le mot suivant
Ctrl+Maj+Gauche Sélectionner le mot précédent
Maj+Fin Sélectionner jusqu'à la fin de la ligne
Maj+Home Sélectionner jusqu'au début de la ligne

Recherche

Raccourcis Action
Ctrl+K Rechercher le suivant
Ctrl+Maj+K Rechercher le précédent
Ctrl+F Rechercher/remplacer
Ctrl+J Rechercher incrémentalement
Ctrl+Maj+J Rechercher anti-incrémentalement (ie. inversée)
Ctrl+G Rechercher la déclaration dans le « workspace »
Ctrl+Alt+G Rechercher le texte dans le « workspace »
Ctrl+H Ouvrir la boite de recherche
Ctrl+Maj+G Rechercher les références dans le « workspace »
Ctrl+Maj+U Rechercher les occurrences

Refactoring

Raccourcis Action
Alt+Maj+C Modifier la signature d'une méthode
Alt+Maj+L Extraire une variable locale
Alt+Maj+M Extraire une méthode
Alt+Maj+R Renommer
Alt+Maj+T Ouvrir le menu de refactoring

Source

Raccourcis Action
Ctrl+Maj+/ Commenter/décommenter le bloc
Ctrl+Maj+M Importer l'élément
Ctrl+Maj+J Initier la Javadoc
Ctrl+Maj+F Formater
Ctrl+I Indenter le bloc
Ctrl+Maj+O Organiser les imports
Alt+Maj+S Ouvrir le menu rapide de source
Alt+Maj+Z Ouvrir le menu rapide d'entourage (pour entourer avec if, try, for, etc.)

Debug

Raccourcis Action
Alt+Maj+D Ouvrir le menu de lancement de debug
F11 Relancer le dernier debug
F11 Relancer le dernier debug
F8 Continuer
Ctrl+F2 Terminer
F5 Aller dans l'instruction (entrer)
F6 Aller à l'instruction suivante
F7 Sortir
Ctrl+Maj+B Ajouter/supprimer un point d'arrêt

Run

Raccourcis Action
Alt+Maj+X Ouvrir le menu de lancement
Ctrl+F11 Relancer la dernière exécution

Fichier

Raccourcis Action
Ctrl+F4 / Ctrl+W Fermer
Ctrl+Maj+F4 / Ctrl+Maj+W Fermer tout
Ctrl+N Créer nouveau (via boite d'assistance)
Alt+Maj+N Créer nouveau (via menu)
Ctrl+P Imprimer
Alt+Entrée Afficher les propriétés
F5 Rafraichir
F2 Renommer
Ctrl+S Sauver
Ctrl+Maj+S Sauver tout

Navigation

Raccourcis Action
Alt+Gauche Retourne au précédent (dans l'historique)
Alt+Droite Retourne au suivant (dans l'historique)
Ctrl+L Aller à une ligne (en indiquant son numéro)
Ctrl+Maj+P Aller à l'accolade correspondante (de l'ouvrante à la fermante, et réciproquement)
Ctrl+Maj+Bas Aller au membre suivant (pour passer d'une méthode à la suivante par exemple)
Ctrl+Maj+Haut Aller au membre précédent
Ctrl+Q Aller au dernier emplacement modifié
Ctrl+Alt+H Ouvrir la fenêtre d'appel hiérarchique
F3 / Ctrl+Clic Aller à la déclaration d'un élément
Maj+F2 Voir la Javadoc externe
Ctrl+Maj+R Ouvrir une ressource (fichier/classe/etc.)
Ctrl+Maj+T Ouvrir un type (classe)
Ctrl+F3 Voir la structure (d'une classe par exemple)
F4 Voir la hiérarchie du type cible
Ctrl+Maj+H Voir la hiérarchie d'un type
Ctrl+T Voir la hiérarchie rapide du type cible
Ctrl+O Voir le « outline » rapide du type cible
Alt+Maj+W Voir menu pour le type cible
Ctrl+F10 Afficher le menu de la vue
Ctrl+M Maximiser/rétablir la vue/perspective
Ctrl+F6 Aller à l'éditeur suivant
Ctrl+Maj+F6 Aller à l'éditeur précédent
Ctrl+F7 Aller à la vue suivante
Ctrl+Maj+F7 Aller à la vue précédente
Ctrl+F8 Aller à la perspective suivante
Ctrl+Maj+F8 Aller à la perspective précédente
Ctrl+E Switcher rapidement d'éditeur
Ctrl+Maj+E Switcher d'éditeur
Ctrl+Maj+L Voir la liste des raccourcis

Bibliographie

Eclipse IDE est un environnement de développement intégré libre extensible, universel et polyvalent.
Il permet de créer des projets de développement mettant en œuvre n'importe quel langage de programmation.
Auto complétion du code avec Eclipse.
Aller dans Préférence>java>editor>contentAssist>Advanced et cocher sur default. 
Ok.png Télécharger Eclipse : http://www.eclipse.org/downloads
Ok.png Télécharger Eclipse PDT : https://eclipse.org/pdt/
Ok.png Les plugins pour Eclipse : http://www.eclipseplugincentral.com
Ok.png Le wiki officiel : http://wiki.eclipse.org/Main_Page
Ok.png Des informations sur Eclipse : http://planeteclipse.org/planet/
Ok.png FAQ Eclipse de Développez : https://eclipse.developpez.com/faq/?page=plateform#frenchEclipse
Ok.png Le forum de développez.com : http://www.developpez.net/forums/f696/environnements-developpement/eclipse/
Ok.png Les raccourcis de Eclipse par Thierry Leriche Dessirier, un article Développez : https://thierry-leriche-dessirier.developpez.com/tutoriels/eclipse/raccourcis/
Ok.png Le forum de developpez.net : Developpement d'application RCP : http://www.developpez.net/forums/f590/environnements-developpement/eclipse/eclipse-java/eclipse-rcp/

NAVIGATION

PARTICIPER ET PARTAGER

Vous êtes sur le wiki de Vision du Web.
Les pages présentées sur le wiki évoluent tous les jours.
Certaines recherches sont peu abouties et incluent des erreurs.
Pour participer sur le wiki, créer un compte utilisateur en haut à droite.
La recherche interne du wiki permet de trouver le contenu qui vous intéresse.
Les informations présentes sur ce wiki sont issues d'une recherche personnelle.
Identifiez-vous pour poser vos questions sur la page de discussion de VisionDuWeb.
Améliorer le contenu des pages en faisant des propositions depuis l'onglet discussion.
Les informations du wiki ne doivent pas servir à nuire à autrui ou à un système informatique.
De nombreux outils gratuits sont listés et disponibles dans la boîte à outils de Vision du web.
D'autres pages du wiki peuvent correspondre à vos attentes. La liste de toutes les pages du wiki.

VALORISER LE WIKI

Valoriser le contenu partagé sur le wiki avec un don en monnaie numérique :
AEON - Bitcoins - Bitcoins Cash - Bitcoins Gold - Bitcore - Blackcoins - Basic Attention Token - Bytecoins - Clams - Dash - Monero - Dogecoins - Ğ1 - Ethereum - Ethereum Classique - Litecoins - Potcoins - Solarcoins - Zcash

OBTENIR DE LA MONNAIE NUMERIQUE

Obtenir gratuitement de la monnaie numérique :
Gagner des Altcoins - Miner des Altcoins.
Consulter le miroir du wiki depuis Planet Hoster : Le miroir du wiki version du 12 Juillet 2019.